dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-apps / rescan-scsi-bus / rescan-scsi-bus-1.57-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Script to rescan the SCSI bus without rebooting"
7 HOMEPAGE="http://www.garloff.de/kurt/linux/"
8 SCRIPT_NAME="${PN}.sh"
9 SRC_NAME="${SCRIPT_NAME}-${PV}"
10 SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
15
16 RDEPEND=">=sys-apps/sg3_utils-1.24
17         <sys-apps/sg3_utils-1.44
18         app-admin/killproc
19         virtual/modutils
20         app-shells/bash"
21
22 S=${WORKDIR}
23
24 src_unpack() {
25         cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
26 }
27
28 src_install() {
29         into /usr
30         dosbin ${SCRIPT_NAME}
31         # Some scripts look for this without the trailing .sh
32         # Some look for it with the trailing .sh, so have a symlink
33         dosym ${SCRIPT_NAME} /usr/sbin/${PN}
34 }