sys-apps/progress: version bump and stable
[gentoo.git] / sys-apps / progress / progress-0.13.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Coreutils Viewer: show progress for cp, rm, dd, and so forth"
9 HOMEPAGE="https://github.com/Xfennec/progress"
10 SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 ppc ppc64 x86"
15
16 RDEPEND="sys-libs/ncurses"
17 DEPEND="
18         ${RDEPEND}
19         virtual/pkgconfig
20 "
21
22 src_prepare() {
23         sed -i \
24                 -e '/CFLAGS/s:-g ::' \
25                 Makefile || die
26         tc-export CC
27 }
28
29 src_install() {
30         emake PREFIX="${D}/${EPREFIX}/usr" install
31         dodoc README.md
32 }