7cde6caae915db51a91d5af3e30f6129392c7a44
[gentoo.git] / sys-apps / progress / progress-0.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit toolchain-funcs
6
7 DESCRIPTION="Coreutils Viewer: show progress for cp, rm, dd, and so forth"
8 HOMEPAGE="https://github.com/Xfennec/progress"
9 SRC_URI="https://github.com/Xfennec/progress/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="amd64 ppc ppc64 x86"
14
15 RDEPEND="sys-libs/ncurses"
16 DEPEND="
17         ${RDEPEND}
18         virtual/pkgconfig
19 "
20
21 src_prepare() {
22         sed -i \
23                 -e '/CFLAGS/s:-g ::' \
24                 Makefile || die
25         tc-export CC
26 }
27
28 src_install() {
29         emake PREFIX="${D}/${EPREFIX}/usr" install
30         dodoc README.md
31 }