dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-apps / powerpc-utils / powerpc-utils-1.1.3.18-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 BASEVER=$(ver_cut 1-3)
9 DEBREV=$(ver_cut 4)
10
11 DESCRIPTION="PowerPC utilities including nvsetenv, and additional OldWorld apps"
12 SRC_URI="http://http.us.debian.org/debian/pool/main/p/powerpc-utils/${PN}_${BASEVER}.orig.tar.gz
13         http://http.us.debian.org/debian/pool/main/p/powerpc-utils/${PN}_${BASEVER}-${DEBREV}.diff.gz
14         mirror://gentoo/${PN}-cleanup.patch.bz2"
15
16 HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/powerpc-utils/"
17 KEYWORDS="-* ppc ppc64"
18 IUSE=""
19 DEPEND=""
20 RDEPEND="${DEPEND}"
21 SLOT="0"
22 LICENSE="GPL-2"
23
24 S="${WORKDIR}/pmac-utils"
25
26 PATCHES=(
27         "${WORKDIR}"/${PN}_${BASEVER}-${DEBREV}.diff
28         "${WORKDIR}"/${PN}-cleanup.patch
29 )
30
31 src_prepare() {
32         default
33
34         # use users CFLAGS, LDFLAGS and CC, bug 280400
35         sed -i -e "/LDFLAGS =/d" -e "/CC\t=/d" -e "s/CFLAGS\t=/CFLAGS +=/" \
36                 -e "s/-g -O2/-Wstrict-prototypes/" Makefile || die "sed failed"
37 }
38
39 src_compile() {
40         tc-export CC
41         emake
42 }
43
44 src_install() {
45         into /usr
46         dosbin autoboot backlight bootsched clock fblevel fdeject fnset
47         dosbin macos mousemode nvsetenv nvsetvol nvvideo sndvolmix trackpad
48
49         doman autoboot.8 bootsched.8 clock.8 fblevel.8 fdeject.8 macos.8
50         doman mousemode.8 nvsetenv.8 nvsetvol.8 nvvideo.8 sndvolmix.8 trackpad.8
51
52         ewarn "The lsprop utility has been moved into the ibm-powerpc-utils package."
53 }