dev-qt/qtgui: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-apps / pkgcore / pkgcore-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_{6..9} )
6 DISTUTILS_IN_SOURCE_BUILD=1
7 inherit distutils-r1
8
9 if [[ ${PV} == *9999 ]] ; then
10         EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
11         inherit git-r3
12 else
13         KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
14         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15 fi
16
17 DESCRIPTION="a framework for package management"
18 HOMEPAGE="https://github.com/pkgcore/pkgcore"
19
20 LICENSE="BSD MIT"
21 SLOT="0"
22 IUSE="test"
23 RESTRICT="!test? ( test )"
24
25 RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
26 if [[ ${PV} == *9999 ]]; then
27         RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
28 else
29         RDEPEND+=" >=dev-python/snakeoil-0.8.7[${PYTHON_USEDEP}]"
30 fi
31 DEPEND="${RDEPEND}
32         dev-python/setuptools[${PYTHON_USEDEP}]
33         test? (
34                 dev-python/pytest[${PYTHON_USEDEP}]
35                 dev-vcs/git
36         )
37 "
38
39 python_test() {
40         esetup.py test
41 }
42
43 python_install_all() {
44         local DOCS=( AUTHORS NEWS.rst )
45         [[ ${PV} == *9999 ]] || doman man/*
46         distutils-r1_python_install_all
47 }