sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / sys-apps / pcsc-tools / pcsc-tools-1.5.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit desktop toolchain-funcs xdg-utils
7
8 DESCRIPTION="PC/SC Architecture smartcard tools"
9 HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
10 SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
15 IUSE="gtk network-cron"
16
17 DEPEND=">=sys-apps/pcsc-lite-1.4.14"
18 RDEPEND="${DEPEND}
19         dev-perl/pcsc-perl
20         gtk? ( dev-perl/Gtk2 )"
21 BDEPEND="virtual/pkgconfig"
22
23 DOCS=(
24         README Changelog
25 )
26
27 src_compile() {
28         # explicitly only build the pcsc_scan application, or the man
29         # pages will be gzipped first, and then unpacked.
30         emake pcsc_scan CC=$(tc-getCC)
31 }
32
33 src_install() {
34         einstalldocs
35
36         # install manually, makes it much easier since the Makefile
37         # requires fiddling with
38         dobin ATR_analysis scriptor pcsc_scan
39         doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
40
41         if use gtk; then
42                 domenu gscriptor.desktop
43                 dobin gscriptor
44                 doman gscriptor.1p
45         fi
46
47         if use network-cron ; then
48                 exeinto /etc/cron.monthly
49                 newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
50         fi
51
52         insinto /usr/share/pcsc
53         doins smartcard_list.txt
54 }
55
56 pkg_postinst() {
57         use gtk && xdg_desktop_database_update
58 }
59
60 pkg_postrm() {
61         xdg_desktop_database_update
62 }