*/*: [QA] Remove redundant --docdir/--htmldir
[gentoo.git] / sys-apps / paxctl / paxctl-0.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit toolchain-funcs eutils
7
8 DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries"
9 HOMEPAGE="https://pax.grsecurity.net"
10 SRC_URI="https://pax.grsecurity.net/${P}.tar.gz"
11
12 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
13 IUSE=""
14 LICENSE="GPL-2"
15 SLOT="0"
16
17 DEPEND=">=sys-devel/binutils-2.14.90.0.8-r1"
18 RDEPEND=""
19
20 src_prepare() {
21         sed \
22                 "s:--owner 0 --group 0::g" \
23                 -i Makefile || die
24         epatch_user
25 }
26
27 src_compile() {
28         emake \
29                 CC="$(tc-getCC)" \
30                 CFLAGS="${CFLAGS}" \
31                 LDFLAGS="${LDFLAGS}"
32 }
33
34 src_install() {
35         emake DESTDIR="${ED}" install
36         dodoc README ChangeLog
37 }