sys-apps/irqbalance: arm64 keyworded (bug #721536)
[gentoo.git] / sys-apps / osinfo-db / osinfo-db-20200325.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="osinfo database files"
7 HOMEPAGE="https://libosinfo.org/"
8 SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
9 S="${WORKDIR}"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15
16 RDEPEND=""
17 DEPEND="${RDEPEND}
18         sys-apps/osinfo-db-tools
19 "
20 # we don't depend on intltool here, contrary to README, as the tarball already
21 # contains the processed results with translations in XML files
22
23 src_unpack() { :; }
24
25 src_install() {
26         osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
27 }