sys-apps/usb_modeswitch: x86 stable (bug #666868)
[gentoo.git] / sys-apps / nvme-cli / nvme-cli-1.6-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="NVM-Express user space tooling for Linux"
9 HOMEPAGE="https://github.com/linux-nvme/nvme-cli"
10 SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 RESTRICT="test"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="+uuid"
17
18 RDEPEND="uuid? ( sys-apps/util-linux:= )"
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         default
23         sed -i 's:^LIBUUID =:LIBUUID ?=:' -i Makefile || die
24 }
25
26 src_configure() {
27         tc-export CC
28         export PREFIX="${EPREFIX}/usr"
29         MAKEOPTS+=" LIBUUID=$(usex uuid 0 1)"
30 }