sys-libs/libnih: stable 1.0.3-r4 for hppa, bug #724174
[gentoo.git] / sys-apps / netloc / netloc-0.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit multilib versionator
7
8 MY_PV=v$(get_version_component_range 1-2)
9
10 DESCRIPTION="Portable Network Locality (netloc)"
11 HOMEPAGE="https://www.open-mpi.org/projects/netloc/"
12 SRC_URI="https://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 DEPEND="
20         dev-libs/jansson
21         <sys-apps/hwloc-2.0"
22 RDEPEND="${DEPEND}"
23
24 src_configure() {
25         econf \
26                 --with-jansson="${EPREFIX}/usr" \
27                 --with-hwloc="${EPREFIX}/usr"
28 }