Set appropriate maintainer types in metadata.xml (GLEP 67)
[gentoo.git] / sys-apps / netkit-base / netkit-base-0.17-r9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Old-style inetd"
10 HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
11 SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
16 IUSE=""
17
18 src_prepare() {
19         epatch "${FILESDIR}"/*.patch
20 }
21
22 src_configure() {
23         tc-export CC
24         ./configure || die
25         sed -i \
26                 -e "/^CFLAGS=/s:=.*:=${CFLAGS} -Wall -Wbad-function-cast -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline:" \
27                 -e "/^LDFLAGS=/s:=.*:=${LDFLAGS}:" \
28                 MCONFIG || die
29 }
30
31 src_install() {
32         sed -i \
33                 -e 's:in\.telnetd$:in.telnetd -L /usr/sbin/telnetlogin:' \
34                 etc.sample/inetd.conf
35
36         dosbin inetd/inetd
37         doman inetd/inetd.8
38         newinitd "${FILESDIR}"/inetd.rc6 inetd
39
40         dodoc BUGS ChangeLog README
41         docinto samples
42         dodoc etc.sample/*
43 }