Remove myself from maintainers
[gentoo.git] / sys-apps / mouseemu / mouseemu-0.15.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Emulates scrollwheel, right- & left-click for one-button mice/touchpads"
7 HOMEPAGE="http://geekounet.org/powerbook/"
8 SRC_URI="mirror://gentoo/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="-* ~ppc"
13 IUSE=""
14
15 DEPEND=""
16
17 S=${WORKDIR}/${PN}
18 PATCHES=(
19         "${FILESDIR}"/${PN}-0.13-fix.patch
20         "${FILESDIR}"/${PN}-0.15-build.patch
21         "${FILESDIR}"/${PN}-0.15-openrc.patch
22 )
23
24 src_install() {
25         dosbin mouseemu
26         einstalldocs
27
28         newinitd mouseemu.init.gentoo mouseemu
29         insinto /etc
30         doins mouseemu.conf
31 }
32
33 pkg_postinst() {
34         einfo "For mouseemu to work you need uinput support in your kernel:"
35         einfo "        CONFIG_INPUT_UINPUT=y"
36         einfo "(Device Drivers->Input device support->Misc->User level driver support)"
37         einfo "Don't forget to add mouseemu to your default runlevel:"
38         einfo "        rc-update add mouseemu default"
39         einfo "Configuration is in /etc/mouseemu.conf."
40 }