sys-apps/openrc: stable 0.41.2 for ia64, bug #684900
[gentoo.git] / sys-apps / mouseemu / mouseemu-0.12.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Emulates scrollwheel, right- & left-click for one-button mice/touchpads"
7 HOMEPAGE="http://geekounet.org/powerbook/"
8 SRC_URI="http://geekounet.org/powerbook/files/${PN}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="-* ppc"
13 IUSE=""
14
15 DEPEND=""
16
17 S=${WORKDIR}/${PN}
18 PATCHES=( "${FILESDIR}"/${P}-fix.diff )
19
20 src_install() {
21         dosbin mouseemu
22         einstalldocs
23
24         newinitd mouseemu.init.gentoo mouseemu
25         insinto /etc
26         doins mouseemu.conf
27 }
28
29 pkg_postinst() {
30         einfo "For mouseemu to work you need uinput support in your kernel:"
31         einfo "        CONFIG_INPUT_UINPUT=y"
32         einfo "(Device Drivers->Input device support->Misc->User level driver support)"
33         einfo "Don't forget to add mouseemu to your default runlevel:"
34         einfo "        rc-update add mouseemu default"
35         einfo "Configuration is in /etc/mouseemu.conf."
36 }