dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / sys-apps / mount-gtk / mount-gtk-1.4.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils flag-o-matic
6
7 DESCRIPTION="GTK+ based UDisks2 frontend"
8 HOMEPAGE="http://mount-gtk.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND=">=dev-libs/glib-2.28
17         sys-fs/udisks:2
18         x11-libs/c++-gtk-utils:0
19         x11-libs/libX11
20         x11-libs/libnotify:="
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 DOCS=( AUTHORS BUGS ChangeLog )
25
26 src_prepare() {
27         epatch "${FILESDIR}"/${P}-c++11.patch
28         sed -i -e 's:AC_CONFIG_HEADER:&S:' configure.ac || die
29         eautoreconf
30 }
31
32 src_configure() {
33         # acinclude.m4 is broken and environment flags override these:
34         append-cxxflags -fexceptions -frtti -fsigned-char -fno-check-new -pthread
35         econf --docdir=/usr/share/doc/${PF}
36 }