Merge branch 'xfim-master'
[gentoo.git] / sys-apps / mawk / mawk-1.3.4_p20150503.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit toolchain-funcs
8
9 MY_P=${P/_p/-}
10 DESCRIPTION="an (often faster than gawk) awk-interpreter"
11 HOMEPAGE="http://invisible-island.net/mawk/mawk.html"
12 SRC_URI="ftp://invisible-island.net/mawk/${MY_P}.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
17
18 RDEPEND="app-eselect/eselect-awk"
19 DEPEND="${RDEPEND}"
20
21 S=${WORKDIR}/${MY_P}
22
23 DOCS=( ACKNOWLEDGMENT CHANGES README )
24
25 src_prepare() {
26         tc-export BUILD_CC
27 }
28
29 src_install() {
30         default
31
32         exeinto /usr/share/doc/${PF}/examples
33         doexe examples/*
34         docompress -x /usr/share/doc/${PF}/examples
35 }
36
37 pkg_postinst() {
38         eselect awk update ifunset
39 }
40
41 pkg_postrm() {
42         eselect awk update ifunset
43 }