sys-apps/irqbalance: arm64 keyworded (bug #721536)
[gentoo.git] / sys-apps / man-pages / man-pages-5.06.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 GENTOO_PATCH=2
7
8 DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
9 HOMEPAGE="https://www.kernel.org/doc/man-pages/"
10 SRC_URI="https://www.kernel.org/pub/linux/docs/man-pages/Archive/${P}.tar.xz
11         https://www.kernel.org/pub/linux/docs/man-pages/${P}.tar.xz
12         mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
13         https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2"
14
15 LICENSE="man-pages GPL-2+ BSD"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
18 IUSE_L10N=" de fr it ja nl pl ru zh-CN"
19 IUSE="${IUSE_L10N// / l10n_}"
20 RESTRICT="binchecks"
21
22 # Block packages that used to install colliding man pages #341953 #548900 #612640 #617462
23 RDEPEND="
24         virtual/man
25         !<sys-apps/keyutils-1.5.9-r4
26         !<dev-libs/libbsd-0.8.3-r1
27 "
28 PDEPEND="
29         l10n_de? ( || ( app-i18n/man-pages-l10n[l10n_de] app-i18n/man-pages-de ) )
30         l10n_fr? ( || ( app-i18n/man-pages-l10n[l10n_fr] app-i18n/man-pages-fr ) )
31         l10n_it? ( app-i18n/man-pages-it )
32         l10n_ja? ( app-i18n/man-pages-ja )
33         l10n_nl? ( || ( app-i18n/man-pages-l10n[l10n_nl] app-i18n/man-pages-nl ) )
34         l10n_pl? ( || ( app-i18n/man-pages-l10n[l10n_pl] app-i18n/man-pages-pl ) )
35         l10n_ru? ( app-i18n/man-pages-ru )
36         l10n_zh-CN? ( app-i18n/man-pages-zh_CN )
37         sys-apps/man-pages-posix
38 "
39
40 src_configure() { :; }
41
42 src_compile() { :; }
43
44 src_install() {
45         emake install prefix="${EPREFIX}/usr" DESTDIR="${D}"
46         dodoc man-pages-*.Announce README Changes*
47
48         # Override with Gentoo specific or additional Gentoo pages
49         cd "${WORKDIR}"/man-pages-gentoo || die
50         doman */*
51         dodoc README.Gentoo
52 }