Merge remote-tracking branch 'github/pr/430'.
[gentoo.git] / sys-apps / man-pages / man-pages-4.01.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 GENTOO_PATCH=2
8
9 DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
10 HOMEPAGE="https://www.kernel.org/doc/man-pages/"
11 SRC_URI="mirror://kernel/linux/docs/man-pages/Archive/${P}.tar.xz
12         mirror://kernel/linux/docs/man-pages/${P}.tar.xz
13         http://man7.org/linux/man-pages/download/${P}.tar.xz
14         mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
15         https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2"
16
17 LICENSE="man-pages GPL-2+ BSD"
18 SLOT="0"
19 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
20 IUSE_LINGUAS=" da de fr it ja nl pl ro ru zh_CN"
21 IUSE="nls ${IUSE_LINGUAS// / linguas_}"
22 RESTRICT="binchecks"
23
24 # Block packages that used to install colliding man pages #341953 #548900
25 RDEPEND="virtual/man
26         !<sys-apps/attr-2.4.47-r2
27         !<dev-libs/libaio-0.3.109-r2"
28 PDEPEND="nls? (
29         linguas_da? ( app-i18n/man-pages-da )
30         linguas_de? ( app-i18n/man-pages-de )
31         linguas_fr? ( app-i18n/man-pages-fr )
32         linguas_it? ( app-i18n/man-pages-it )
33         linguas_ja? ( app-i18n/man-pages-ja )
34         linguas_nl? ( app-i18n/man-pages-nl )
35         linguas_pl? ( app-i18n/man-pages-pl )
36         linguas_ro? ( app-i18n/man-pages-ro )
37         linguas_ru? ( app-i18n/man-pages-ru )
38         linguas_zh_CN? ( app-i18n/man-pages-zh_CN )
39         )
40         sys-apps/man-pages-posix"
41
42 src_configure() { :; }
43
44 src_compile() { :; }
45
46 src_install() {
47         emake install prefix="${EPREFIX}/usr" DESTDIR="${D}"
48         dodoc man-pages-*.Announce README Changes*
49
50         # Override with Gentoo specific or additional Gentoo pages
51         cd "${WORKDIR}"/man-pages-gentoo
52         doman */*
53         dodoc README.Gentoo
54 }