media-gfx/gscan2pdf: remove old 2.6.5
[gentoo.git] / sys-apps / lsd / lsd-0.17.0.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CRATES="
7 aho-corasick-0.7.6
8 ansi_term-0.11.0
9 ansi_term-0.12.1
10 assert_cmd-0.11.1
11 assert_fs-0.11.3
12 atty-0.2.13
13 autocfg-0.1.7
14 bitflags-1.2.1
15 bstr-0.2.8
16 c2-chacha-0.2.3
17 cfg-if-0.1.10
18 chrono-0.4.9
19 chrono-humanize-0.0.11
20 clap-2.33.0
21 crossbeam-channel-0.3.9
22 crossbeam-utils-0.6.6
23 difference-2.0.0
24 escargot-0.4.0
25 float-cmp-0.4.0
26 fnv-1.0.6
27 getrandom-0.1.12
28 glob-0.3.0
29 globset-0.4.4
30 globwalk-0.5.0
31 ignore-0.4.10
32 itoa-0.4.4
33 kernel32-sys-0.2.2
34 lazy_static-1.4.0
35 libc-0.2.65
36 log-0.4.8
37 lscolors-0.6.0
38 lsd-0.17.0
39 memchr-2.2.1
40 normalize-line-endings-0.2.2
41 num-integer-0.1.41
42 num-traits-0.2.8
43 ppv-lite86-0.2.6
44 predicates-1.0.1
45 predicates-core-1.0.0
46 predicates-tree-1.0.0
47 proc-macro2-1.0.6
48 quote-1.0.2
49 rand-0.7.2
50 rand_chacha-0.2.1
51 rand_core-0.5.1
52 rand_hc-0.2.0
53 redox_syscall-0.1.56
54 regex-1.3.1
55 regex-syntax-0.6.12
56 remove_dir_all-0.5.2
57 ryu-1.0.2
58 same-file-1.0.5
59 serde-1.0.101
60 serde_derive-1.0.101
61 serde_json-1.0.41
62 strsim-0.8.0
63 syn-1.0.5
64 tempfile-3.1.0
65 term_grid-0.1.7
66 term_size-0.3.1
67 terminal_size-0.1.8
68 textwrap-0.11.0
69 thread_local-0.3.6
70 time-0.1.42
71 treeline-0.1.0
72 unicode-width-0.1.6
73 unicode-xid-0.2.0
74 users-0.9.1
75 vec_map-0.8.1
76 version_check-0.9.1
77 walkdir-2.2.9
78 wasi-0.7.0
79 wild-2.0.2
80 winapi-0.2.8
81 winapi-0.3.8
82 winapi-build-0.1.1
83 winapi-i686-pc-windows-gnu-0.4.0
84 winapi-util-0.1.2
85 winapi-x86_64-pc-windows-gnu-0.4.0
86 "
87
88 inherit cargo
89
90 DESCRIPTION="A modern ls with a lot of pretty colors and awesome icons"
91 HOMEPAGE="https://github.com/Peltoche/lsd"
92 SRC_URI="https://github.com/Peltoche/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
93         $(cargo_crate_uris ${CRATES})"
94
95 LICENSE="Apache-2.0 BSD-2 ISC MIT"
96 SLOT="0"
97 KEYWORDS="~amd64 ~ppc64 ~x86"
98 IUSE=""
99
100 DEPEND=""
101 RDEPEND=""
102 BDEPEND=""
103
104 QA_FLAGS_IGNORED="/usr/bin/lsd"
105
106 src_install() {
107         cargo_src_install
108         einstalldocs
109 }