dev-ruby/rex-text: cleanup
[gentoo.git] / sys-apps / lsb-release / lsb-release-1.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 DESCRIPTION="LSB version query program"
5 HOMEPAGE="https://wiki.linuxfoundation.org/lsb/"
6 SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
7
8 LICENSE="GPL-2"
9 SLOT="0"
10 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
11 IUSE=""
12
13 # Perl isn't needed at runtime, it is just used to generate the man page.
14 DEPEND="dev-lang/perl"
15 RDEPEND=""
16
17 src_install() {
18         emake \
19                 prefix="${D}/usr" \
20                 mandir="${D}/usr/share/man" \
21                 install \
22                 || die "emake install failed"
23
24         mkdir -p "${D}/etc"
25         cat > "${D}/etc/lsb-release" <<- EOF
26                 DISTRIB_ID="Gentoo"
27         EOF
28 }