sys-apps/lsvpd: bump to 1.7.11
[gentoo.git] / sys-apps / input-utils / input-utils-1.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils
6
7 MY_PN="input"
8 MY_P="${MY_PN}-${PV}"
9
10 DESCRIPTION="Small collection of linux input layer utils"
11 HOMEPAGE="https://www.kraxel.org/blog/linux/input/"
12 SRC_URI="https://www.kraxel.org/releases/input/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~arm64 ppc x86"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND=""
21
22 S="${WORKDIR}/${MY_P}"
23
24 src_prepare() {
25         # Ported from Debian
26         #epatch "${FILESDIR}"/input-utils-0.0.1_pre20081014.patch
27         # version check stuff
28         #epatch "${FILESDIR}"/input-utils-0.0.1-protocol-mismatch-fix.patch
29         :
30 }
31
32 src_install() {
33         make install bindir="${D}"/usr/bin mandir="${D}"/usr/share/man STRIP="" || die "make install failed"
34         dodoc lircd.conf
35         dodoc README
36 }