sys-apps/groff: stable 1.22.4 for ppc64, bug #704420
[gentoo.git] / sys-apps / ifplugd / ifplugd-0.28-r11.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
7 HOMEPAGE="http://0pointer.de/lennart/projects/ifplugd/"
8 SRC_URI="http://0pointer.de/lennart/projects/ifplugd/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ~arm64 hppa ppc x86"
13 IUSE="doc selinux"
14
15 DEPEND="virtual/pkgconfig
16         doc? ( www-client/lynx )
17         >=dev-libs/libdaemon-0.5"
18 RDEPEND=">=dev-libs/libdaemon-0.5
19         >=sys-apps/baselayout-1.12
20         selinux? ( sec-policy/selinux-ifplugd )"
21
22 PATCHES=(
23         "${FILESDIR}/${P}-nlapi.diff"
24         "${FILESDIR}/${P}-interface.patch"
25         "${FILESDIR}/${P}-strictalias.patch"
26         "${FILESDIR}/${P}-noip.patch"
27         "${FILESDIR}/${P}-musl.patch"
28         "${FILESDIR}/${P}-gcc10-compatibility.patch"
29 )
30
31 DOCS=( doc/README doc/SUPPORTED_DRIVERS )
32 HTML_DOCS=( doc/README.html doc/style.css )
33
34 src_configure() {
35         econf \
36                 $(use_enable doc lynx) \
37                 --with-initdir=/etc/init.d \
38                 --disable-xmltoman \
39                 --disable-subversion
40 }
41
42 src_install() {
43         default
44
45         # Remove init.d configuration as we no longer use it
46         rm -rf "${ED}/etc/ifplugd" "${ED}/etc/init.d/${PN}" || die
47
48         exeinto "/etc/${PN}"
49         newexe "${FILESDIR}/${PN}.action" "${PN}.action"
50 }