a78a768b20f6e43639a348b73bbd2effab6afa53
[gentoo.git] / sys-apps / ibm-powerpc-utils-papr / ibm-powerpc-utils-papr-1.1.6.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils
5
6 MY_P="powerpc-utils-papr-${PV}"
7
8 DESCRIPTION="Utilities for the maintenance of IBM PowerPC platforms"
9 SRC_URI="http://powerpc-utils.ozlabs.org/releases/powerpc-utils-papr-${PV}.tar.gz"
10 HOMEPAGE="http://powerpc-utils.ozlabs.org/"
11
12 S="${WORKDIR}/${MY_P}"
13
14 SLOT="0"
15 LICENSE="IBM"
16 KEYWORDS="~ppc ~ppc64"
17 IUSE=""
18 RDEPEND=">=sys-apps/ibm-powerpc-utils-1.1.2
19         sys-libs/librtas
20         virtual/logger"
21
22 src_unpack() {
23         unpack ${A}
24         epatch "${FILESDIR}"/ibm-powerpc-utils-papr-${PV}-removeinitandvscsis.patch
25 }
26
27 src_install() {
28         make DESTDIR="${D}" install || die "Compilation failed"
29 }
30
31 pkg_postinst() {
32         einfo "Support for the IBM Virtual SCSI server (virtual disk) "
33         einfo "is not included in this version of powerpc-utils-papr. "
34         einfo "When the ibmvscsis function is generally available in  "
35         einfo "the kernel source trees, it will be added back in."
36 }