19f2a4f32884d13d1d3bf8c3061f0d0792b4039c
[gentoo.git] / sys-apps / ibm-powerpc-utils-papr / ibm-powerpc-utils-papr-1.1.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils
7
8 MY_P="powerpc-utils-papr-${PV}"
9
10 DESCRIPTION="Utilities for the maintenance of IBM PowerPC platforms"
11 SRC_URI="http://powerpc-utils.ozlabs.org/releases/powerpc-utils-papr-${PV}.tar.gz"
12 HOMEPAGE="http://powerpc-utils.ozlabs.org/"
13
14 S="${WORKDIR}/${MY_P}"
15
16 SLOT="0"
17 LICENSE="IBM"
18 KEYWORDS="~ppc ~ppc64"
19 IUSE=""
20 RDEPEND=">=sys-apps/ibm-powerpc-utils-1.1.2
21         sys-libs/librtas
22         virtual/logger"
23
24 src_unpack() {
25         unpack ${A}
26         epatch "${FILESDIR}"/ibm-powerpc-utils-papr-${PV}-removeinitandvscsis.patch
27 }
28
29 src_install() {
30         make DESTDIR="${D}" install || die "Compilation failed"
31 }
32
33 pkg_postinst() {
34         einfo "Support for the IBM Virtual SCSI server (virtual disk) "
35         einfo "is not included in this version of powerpc-utils-papr. "
36         einfo "When the ibmvscsis function is generally available in  "
37         einfo "the kernel source trees, it will be added back in."
38 }