sys-apps/gsmartcontrol: amd64 stable wrt bug #664360
[gentoo.git] / sys-apps / gsmartcontrol / gsmartcontrol-1.1.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit flag-o-matic gnome2-utils
6
7 DESCRIPTION="Hard disk drive health inspection tool"
8 HOMEPAGE="https://gsmartcontrol.sourceforge.io/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15
16 COMMON_DEPEND="
17         dev-cpp/gtkmm:3.0
18         dev-libs/libpcre:3
19         sys-apps/smartmontools
20 "
21 RDEPEND="${COMMON_DEPEND}
22         x11-apps/xmessage
23 "
24 DEPEND="${COMMON_DEPEND}
25         virtual/pkgconfig
26         test? ( dev-util/gtk-builder-convert )
27 "
28
29 DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
30
31 src_prepare() {
32         default
33         append-cxxflags -std=c++11
34 }
35
36 src_configure() {
37         econf $(use test tests)
38 }
39
40 src_install() {
41         default
42         rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
43 }
44
45 pkg_preinst() { gnome2_icon_savelist; }
46 pkg_postinst() { gnome2_icon_cache_update; }
47 pkg_postrm() { gnome2_icon_cache_update; }