sys-apps/irqbalance: arm64 keyworded (bug #721536)
[gentoo.git] / sys-apps / gentoo-functions / gentoo-functions-0.13.ebuild
1 # Copyright 2014-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 if [[ ${PV} == 9999* ]]; then
7         inherit git-r3
8         EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
9 else
10         SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
11         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
12 fi
13
14 inherit toolchain-funcs flag-o-matic
15
16 DESCRIPTION="base functions required by all Gentoo systems"
17 HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
18
19 LICENSE="GPL-2"
20 SLOT="0"
21 IUSE=""
22
23 src_configure() {
24         tc-export CC
25         append-lfs-flags
26         export ROOTPREFIX="${EPREFIX}"
27         export PREFIX="${EPREFIX}/usr"
28 }