sys-apps/fd: bump to 8.1.1
[gentoo.git] / sys-apps / firejail-lts / firejail-lts-0.9.56.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Security sandbox for any type of processes; LTS version"
7 HOMEPAGE="https://firejail.wordpress.com/"
8
9 MY_PN=firejail
10
11 SRC_URI="https://github.com/netblue30/${MY_PN}/archive/${PV}-LTS.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64"
16 IUSE="apparmor +globalcfg +network +seccomp +suid +userns test +whitelist"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="!sys-apps/firejail
20                 apparmor? ( sys-libs/libapparmor )
21                 test? ( dev-tcltk/expect )"
22
23 RDEPEND="apparmor? ( sys-libs/libapparmor )"
24
25 PATCHES=( "${FILESDIR}/${PN}-fix-compressed-manpages.patch" )
26
27 S="${WORKDIR}/${MY_PN}-${PV}-LTS"
28
29 src_prepare() {
30         default
31
32         find -type f -name Makefile.in | xargs sed --in-place --regexp-extended \
33                 --expression='/^\tinstall .*COPYING /d' \
34                 --expression='/CFLAGS/s: (-O2|-ggdb) : :g' || die
35
36         sed --in-place --regexp-extended '/CFLAGS/s: (-O2|-ggdb) : :g' ./src/common.mk.in || die
37 }
38
39 src_configure() {
40         econf \
41                 $(use_enable apparmor) \
42                 $(use_enable globalcfg) \
43                 $(use_enable network) \
44                 $(use_enable seccomp) \
45                 $(use_enable suid) \
46                 $(use_enable userns) \
47                 $(use_enable whitelist)
48 }