387e1a904e2528a2e3916c23e8f8092fbe9e0bcc
[gentoo.git] / sys-apps / fbset / fbset-2.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs flag-o-matic eutils
7
8 DESCRIPTION="A utility to set the framebuffer videomode"
9 HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
10 SRC_URI="http://users.telenet.be/geertu/Linux/fbdev/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86"
15 IUSE="static"
16
17 DEPEND="sys-devel/bison
18         sys-devel/flex"
19 RDEPEND=""
20
21 src_prepare() {
22         epatch "${FILESDIR}/${P}-build.patch"
23         epatch "${FILESDIR}/${P}-add-linux-types-h.patch"
24         default
25 }
26
27 src_compile() {
28         use static && append-ldflags -static
29         tc-export CC
30         emake
31 }
32
33 src_install() {
34         dobin fbset modeline2fb
35         doman *.[58]
36         dodoc etc/fb.modes.* INSTALL
37 }