sys-apps/gawk: stable 5.0.1 for ppc64, bug #725374
[gentoo.git] / sys-apps / dmapi / dmapi-2.2.12-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils toolchain-funcs ltprune multilib multilib-minimal usr-ldscript
7
8 DESCRIPTION="XFS data management API library"
9 HOMEPAGE="https://xfs.wiki.kernel.org/"
10 SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
11         ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
16 IUSE="static-libs"
17
18 RDEPEND="sys-fs/xfsprogs"
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         sed -i \
23                 -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
24                 include/builddefs.in \
25                 || die
26         epatch "${FILESDIR}"/${P}-headers.patch
27
28         multilib_copy_sources
29 }
30
31 multilib_src_configure() {
32         export OPTIMIZER=${CFLAGS}
33         export DEBUG=-DNDEBUG
34
35         econf \
36                 --libexecdir=/usr/$(get_libdir) \
37                 $(use_enable static-libs static)
38 }
39
40 multilib_src_install() {
41         emake DESTDIR="${D}" install install-dev
42         gen_usr_ldscript -a dm
43 }
44
45 multilib_src_install_all() {
46         prune_libtool_files --all
47         rm "${ED}"/usr/share/doc/${PF}/COPYING
48 }