sys-apps/irqbalance: arm64 keyworded (bug #721536)
[gentoo.git] / sys-apps / diffutils / diffutils-3.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit flag-o-matic
7
8 DESCRIPTION="Tools to make diffs and compare files"
9 HOMEPAGE="https://www.gnu.org/software/diffutils/"
10 SRC_URI="mirror://gnu/diffutils/${P}.tar.xz
11         mirror://gnu-alpha/diffutils/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="nls static"
17
18 DEPEND="app-arch/xz-utils
19         nls? ( sys-devel/gettext )"
20
21 DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
22
23 src_configure() {
24         use static && append-ldflags -static
25
26         # Disable automagic dependency over libsigsegv; see bug #312351.
27         export ac_cv_libsigsegv=no
28
29         # required for >=glibc-2.26, bug #653914
30         use elibc_glibc && export gl_cv_func_getopt_gnu=yes
31
32         local myeconfargs=(
33                 --with-packager="Gentoo"
34                 --with-packager-version="${PVR}"
35                 --with-packager-bug-reports="https://bugs.gentoo.org/"
36                 $(use_enable nls)
37         )
38         econf "${myeconfargs[@]}"
39 }
40
41 src_test() {
42         # explicitly allow parallel testing
43         emake check
44 }