sys-apps/openrc: arm64 stable wrt bug #684900
[gentoo.git] / sys-apps / cobalt-panel-utils / cobalt-panel-utils-1.0.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="2"
5
6 inherit eutils
7
8 DESCRIPTION="LCD and LED panel utilities for the Sun Cobalts"
9 HOMEPAGE="http://gentoo.404ster.com/"
10 SRC_URI="ftp://www.404ster.com/pub/gentoo-stuff/ebuilds/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~mips x86"
15 IUSE="static"
16
17 RDEPEND="sys-devel/gettext"
18 DEPEND="${DEPEND}
19         sys-devel/autoconf"
20
21 src_configure() {
22         sed -i \
23                 -e"/^COPTS/s:= := ${CFLAGS} :" \
24                 -e"/^LDFLAGS/s:= := ${LDFLAGS} :"\
25                 Makefile || die "sed failed"
26 }
27
28 src_compile() {
29         if use static; then
30                 einfo "Building as static executables"
31                 export STATIC="-static"
32         fi
33         emake || die
34 }
35
36 src_install() {
37         into /
38         dosbin  "${S}"/lcd-flash "${S}"/lcd-getip "${S}"/lcd-swrite \
39         "${S}"/lcd-write "${S}"/lcd-yesno "${S}"/lcd-setcursor "${S}"/iflink
40         "${S}"/iflinkstatus "${S}"/readbutton || die "dosbin failed"
41
42         dodoc doc/README* doc/CREDITS
43         doman doc/man/*.1
44 }