www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / sys-apps / bubblewrap / bubblewrap-0.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit bash-completion-r1 linux-info
7
8 DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
9 HOMEPAGE="https://github.com/containers/bubblewrap/"
10 SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
11
12 LICENSE="LGPL-2+"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
15 IUSE="selinux +suid"
16
17 RDEPEND="
18         sys-libs/libseccomp
19         sys-libs/libcap
20         selinux? ( >=sys-libs/libselinux-2.1.9 )
21 "
22 DEPEND="${RDEPEND}
23         app-text/docbook-xml-dtd:4.3
24         app-text/docbook-xsl-stylesheets
25         dev-libs/libxslt
26         virtual/pkgconfig
27 "
28
29 # tests require root priviledge
30 RESTRICT="test"
31 PATCHES=(
32         "${FILESDIR}/bubblewrap-0.3.1-selinux-configure.patch" # bug 674312
33 )
34
35 pkg_setup() {
36         if [[ ${MERGE_TYPE} != buildonly ]]; then
37                 CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
38                 linux-info_pkg_setup
39         fi
40 }
41
42 src_configure() {
43         econf \
44                 $(use_enable selinux) \
45                 "--enable-man" \
46                 "--with-bash-completion-dir=$(get_bashcompdir)" \
47                 "--with-priv-mode=$(usex suid setuid none)"
48 }