dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-apps / bat / bat-0.15.0.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CRATES="
7 adler32-1.0.4
8 aho-corasick-0.7.10
9 ansi_colours-1.0.1
10 ansi_term-0.11.0
11 ansi_term-0.12.1
12 anymap-0.12.1
13 arrayref-0.3.6
14 arrayvec-0.5.1
15 assert_cmd-1.0.1
16 atty-0.2.14
17 autocfg-1.0.0
18 backtrace-0.3.46
19 backtrace-sys-0.1.36
20 base64-0.10.1
21 base64-0.11.0
22 bincode-1.2.1
23 bindgen-0.50.1
24 bit-set-0.5.1
25 bit-vec-0.5.1
26 bitflags-1.2.1
27 blake2b_simd-0.5.10
28 block-buffer-0.7.3
29 block-padding-0.1.5
30 bstr-0.2.12
31 byte-tools-0.3.1
32 byteorder-1.3.4
33 cc-1.0.52
34 cexpr-0.3.6
35 cfg-if-0.1.10
36 chrono-0.4.11
37 clang-sys-0.28.1
38 clap-2.33.0
39 clicolors-control-1.0.1
40 console-0.10.0
41 constant_time_eq-0.1.5
42 content_inspector-0.2.4
43 crc32fast-1.2.0
44 crossbeam-utils-0.7.2
45 difference-2.0.0
46 digest-0.8.1
47 dirs-2.0.2
48 dirs-sys-0.3.4
49 doc-comment-0.3.3
50 dtoa-0.4.5
51 either-1.5.3
52 encode_unicode-0.3.6
53 encoding-0.2.33
54 encoding-index-japanese-1.20141219.5
55 encoding-index-korean-1.20141219.5
56 encoding-index-simpchinese-1.20141219.5
57 encoding-index-singlebyte-1.20141219.5
58 encoding-index-tradchinese-1.20141219.5
59 encoding_index_tests-0.1.4
60 env_logger-0.6.2
61 error-chain-0.12.2
62 failure-0.1.7
63 fake-simd-0.1.2
64 fancy-regex-0.3.3
65 flate2-1.0.14
66 fnv-1.0.6
67 fuchsia-cprng-0.1.1
68 fxhash-0.2.1
69 generic-array-0.12.3
70 getrandom-0.1.14
71 git2-0.13.3
72 glob-0.3.0
73 globset-0.4.5
74 hermit-abi-0.1.11
75 humantime-1.3.0
76 idna-0.1.5
77 idna-0.2.0
78 indexmap-1.3.2
79 itertools-0.8.2
80 itoa-0.4.5
81 jobserver-0.1.21
82 kernel32-sys-0.2.2
83 kstring-0.1.0
84 lazy_static-1.4.0
85 lazycell-1.2.1
86 libc-0.2.69
87 libgit2-sys-0.12.4+1.0.0
88 libloading-0.5.2
89 libz-sys-1.0.25
90 line-wrap-0.1.1
91 linked-hash-map-0.5.2
92 liquid-0.20.0
93 liquid-core-0.20.0
94 liquid-derive-0.20.0
95 liquid-lib-0.20.0
96 log-0.4.8
97 maplit-1.0.2
98 matches-0.1.8
99 memchr-2.3.3
100 miniz_oxide-0.3.6
101 nom-4.2.3
102 num-integer-0.1.42
103 num-traits-0.2.11
104 once_cell-1.3.1
105 onig-5.0.0
106 onig_sys-69.2.0
107 opaque-debug-0.2.3
108 peeking_take_while-0.1.2
109 percent-encoding-1.0.1
110 percent-encoding-2.1.0
111 pest-2.1.3
112 pest_derive-2.1.0
113 pest_generator-2.1.3
114 pest_meta-2.1.3
115 pkg-config-0.3.17
116 plist-0.5.5
117 predicates-1.0.4
118 predicates-core-1.0.0
119 predicates-tree-1.0.0
120 proc-macro-hack-0.5.15
121 proc-macro2-0.4.30
122 proc-macro2-1.0.10
123 proc-quote-0.3.2
124 proc-quote-impl-0.3.2
125 quick-error-1.2.3
126 quote-0.6.13
127 quote-1.0.3
128 rand-0.4.6
129 rand_core-0.3.1
130 rand_core-0.4.2
131 rdrand-0.4.0
132 redox_syscall-0.1.56
133 redox_users-0.3.4
134 regex-1.3.7
135 regex-syntax-0.6.17
136 remove_dir_all-0.5.2
137 rust-argon2-0.7.0
138 rustc-demangle-0.1.16
139 ryu-1.0.3
140 safemem-0.3.3
141 same-file-1.0.6
142 semver-0.9.0
143 semver-parser-0.7.0
144 serde-1.0.106
145 serde_derive-1.0.106
146 serde_json-1.0.51
147 serde_yaml-0.8.11
148 sha-1-0.8.2
149 shell-words-0.1.0
150 shlex-0.1.1
151 smallvec-1.3.0
152 strsim-0.8.0
153 syn-1.0.17
154 syntect-4.1.1
155 tempdir-0.3.7
156 term_size-0.3.1
157 termcolor-1.1.0
158 termios-0.3.2
159 textwrap-0.11.0
160 thread_local-1.0.1
161 time-0.1.43
162 treeline-0.1.0
163 typenum-1.12.0
164 ucd-trie-0.1.3
165 unicode-bidi-0.3.4
166 unicode-normalization-0.1.12
167 unicode-segmentation-1.6.0
168 unicode-width-0.1.7
169 unicode-xid-0.1.0
170 unicode-xid-0.2.0
171 url-1.7.2
172 url-2.1.1
173 vcpkg-0.2.8
174 vec_map-0.8.1
175 version_check-0.1.5
176 version_check-0.9.1
177 wait-timeout-0.2.0
178 walkdir-2.3.1
179 wasi-0.9.0+wasi-snapshot-preview1
180 which-2.0.1
181 wild-2.0.2
182 winapi-0.2.8
183 winapi-0.3.8
184 winapi-build-0.1.1
185 winapi-i686-pc-windows-gnu-0.4.0
186 winapi-util-0.1.5
187 winapi-x86_64-pc-windows-gnu-0.4.0
188 xml-rs-0.8.2
189 yaml-rust-0.4.3
190 "
191
192 inherit cargo
193
194 DESCRIPTION="cat(1) clone with syntax highlighting and Git integration"
195 HOMEPAGE="https://github.com/sharkdp/bat"
196 SRC_URI="https://github.com/sharkdp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
197         $(cargo_crate_uris ${CRATES})"
198
199 LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 CC0-1.0 ISC LGPL-3+ MIT Apache-2.0 Unlicense ZLIB"
200 SLOT="0"
201 KEYWORDS="~amd64 ~ppc64 ~x86"
202
203 DEPEND="sys-libs/zlib"
204
205 # >app-backup/bacula-9.2[qt5] has file collisions, #686118
206 RDEPEND="${DEPEND}
207         !>app-backup/bacula-9.2[qt5]
208 "
209
210 BDEPEND="sys-devel/clang"
211
212 DOCS=( README.md doc/alternatives.md )
213
214 QA_FLAGS_IGNORED="/usr/bin/bat"
215
216 src_install() {
217         cargo_src_install
218         doman target/release/build/bat-*/out/assets/manual/bat.1
219         einstalldocs
220         insinto /usr/share/fish/vendor_completions.d/
221         doins target/release/build/bat-*/out/assets/completions/bat.fish
222 }