dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-apps / bat / bat-0.12.1-r1.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CRATES="
7 adler32-1.0.3
8 aho-corasick-0.7.6
9 ansi_colours-1.0.1
10 ansi_term-0.11.0
11 ansi_term-0.12.1
12 arrayref-0.3.5
13 arrayvec-0.4.11
14 assert_cmd-0.11.1
15 atty-0.2.13
16 autocfg-0.1.6
17 backtrace-0.3.35
18 backtrace-sys-0.1.31
19 base64-0.10.1
20 bat-0.12.1
21 bincode-1.1.4
22 bindgen-0.50.0
23 bitflags-1.1.0
24 blake2b_simd-0.5.7
25 byteorder-1.3.2
26 cc-1.0.41
27 cexpr-0.3.5
28 cfg-if-0.1.9
29 clang-sys-0.28.1
30 clap-2.33.0
31 clicolors-control-1.0.1
32 cloudabi-0.0.3
33 console-0.8.0
34 constant_time_eq-0.1.4
35 content_inspector-0.2.4
36 crc32fast-1.2.0
37 crossbeam-utils-0.6.6
38 difference-2.0.0
39 dirs-2.0.2
40 dirs-sys-0.3.4
41 encode_unicode-0.3.6
42 encoding-0.2.33
43 encoding-index-japanese-1.20141219.5
44 encoding-index-korean-1.20141219.5
45 encoding-index-simpchinese-1.20141219.5
46 encoding-index-singlebyte-1.20141219.5
47 encoding-index-tradchinese-1.20141219.5
48 encoding_index_tests-0.1.4
49 env_logger-0.6.2
50 error-chain-0.12.1
51 escargot-0.4.0
52 escargot-0.5.0
53 failure-0.1.5
54 failure_derive-0.1.5
55 flate2-1.0.11
56 fnv-1.0.6
57 fuchsia-cprng-0.1.1
58 fxhash-0.2.1
59 git2-0.10.0
60 glob-0.3.0
61 humantime-1.2.0
62 idna-0.2.0
63 itoa-0.4.4
64 kernel32-sys-0.2.2
65 lazy_static-1.4.0
66 lazycell-1.2.1
67 libc-0.2.62
68 libgit2-sys-0.9.0
69 libloading-0.5.2
70 libz-sys-1.0.25
71 line-wrap-0.1.1
72 linked-hash-map-0.5.2
73 log-0.4.8
74 matches-0.1.8
75 memchr-2.2.1
76 miniz-sys-0.1.12
77 miniz_oxide-0.3.2
78 nodrop-0.1.13
79 nom-4.2.3
80 onig-5.0.0
81 onig_sys-69.2.0
82 peeking_take_while-0.1.2
83 percent-encoding-2.1.0
84 pkg-config-0.3.15
85 plist-0.4.2
86 predicates-1.0.1
87 predicates-core-1.0.0
88 predicates-tree-1.0.0
89 proc-macro2-0.4.30
90 proc-macro2-1.0.2
91 quick-error-1.2.2
92 quote-0.6.13
93 quote-1.0.2
94 rand-0.4.6
95 rand_core-0.3.1
96 rand_core-0.4.2
97 rand_os-0.1.3
98 rdrand-0.4.0
99 redox_syscall-0.1.56
100 redox_users-0.3.1
101 regex-1.2.1
102 regex-syntax-0.6.11
103 remove_dir_all-0.5.2
104 rust-argon2-0.5.1
105 rustc-demangle-0.1.16
106 ryu-1.0.0
107 safemem-0.3.2
108 same-file-1.0.5
109 serde-1.0.99
110 serde_derive-1.0.99
111 serde_json-1.0.40
112 shell-words-0.1.0
113 shlex-0.1.1
114 smallvec-0.6.10
115 strsim-0.8.0
116 syn-0.15.44
117 syn-1.0.5
118 synstructure-0.10.2
119 syntect-3.2.1
120 tempdir-0.3.7
121 term_size-0.3.1
122 termcolor-1.0.5
123 termios-0.3.1
124 textwrap-0.11.0
125 thread_local-0.3.6
126 treeline-0.1.0
127 unicode-bidi-0.3.4
128 unicode-normalization-0.1.8
129 unicode-width-0.1.6
130 unicode-xid-0.1.0
131 unicode-xid-0.2.0
132 url-2.1.0
133 vcpkg-0.2.7
134 vec_map-0.8.1
135 version_check-0.1.5
136 walkdir-2.2.9
137 which-2.0.1
138 wild-2.0.2
139 winapi-0.2.8
140 winapi-0.3.8
141 winapi-build-0.1.1
142 winapi-i686-pc-windows-gnu-0.4.0
143 winapi-util-0.1.2
144 winapi-x86_64-pc-windows-gnu-0.4.0
145 wincolor-1.0.2
146 xml-rs-0.8.0
147 yaml-rust-0.4.3
148 "
149
150 inherit cargo
151
152 DESCRIPTION="cat(1) clone with syntax highlighting and Git integration"
153 HOMEPAGE="https://github.com/sharkdp/bat"
154 SRC_URI="$(cargo_crate_uris ${CRATES})"
155
156 LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 CC0-1.0 ISC LGPL-3+ MIT Apache-2.0 Unlicense ZLIB"
157 SLOT="0"
158 KEYWORDS="~amd64 ~ppc64 ~x86"
159
160 DEPEND="sys-libs/zlib"
161
162 # >app-backup/bacula-9.2[qt5] has file collisions, #686118
163 RDEPEND="${DEPEND}
164         !>app-backup/bacula-9.2[qt5]
165 "
166
167 BDEPEND="sys-devel/clang"
168
169 DOCS=( README.md doc/alternatives.md )
170
171 QA_FLAGS_IGNORED="/usr/bin/bat"
172
173 src_install() {
174         cargo_src_install
175         doman doc/bat.1
176         einstalldocs
177         insinto /usr/share/fish/vendor_completions.d/
178         doins assets/completions/bat.fish
179 }