Merge branch 'pull895'
[gentoo.git] / sys-apps / baobab / baobab-3.16.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7
8 inherit gnome2
9
10 DESCRIPTION="Disk usage browser for GNOME"
11 HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
12
13 LICENSE="GPL-2+ FDL-1.1+"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
17
18 COMMON_DEPEND="
19         >=dev-libs/glib-2.40:2
20         >=x11-libs/gtk+-3.13.2:3
21 "
22 RDEPEND="${COMMON_DEPEND}
23         gnome-base/gsettings-desktop-schemas
24         x11-themes/gnome-icon-theme-extras
25         !<gnome-extra/gnome-utils-3.4
26 "
27 # ${PN} was part of gnome-utils before 3.4
28 DEPEND="${COMMON_DEPEND}
29         dev-libs/libxml2
30         >=dev-util/intltool-0.40
31         >=sys-devel/gettext-0.17
32         virtual/pkgconfig
33 "
34
35 src_configure() {
36         gnome2_src_configure   \
37                 ITSTOOL=$(type -P true) \
38                 VALAC=$(type -P true)  \
39                 VAPIGEN=$(type -P true)
40 }