sys-apps/agedu: HOMEPAGE and SRC_URI 301 redirect to HTTPS
[gentoo.git] / sys-apps / agedu / agedu-20151213.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit autotools eutils
7
8 # agedu-20151213.59b0ed3.ebuild is not a legitimate name
9 # so we'll drop versionator and just set MY_P manually.
10 MY_P="${PN}"-20151213.59b0ed3
11
12 DESCRIPTION="A utility for tracking down wasted disk space"
13 HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/agedu/"
14 SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/agedu/${MY_P}.tar.gz -> ${MY_P}.tar.gz"
15 S="${WORKDIR}/${MY_P}"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="doc ipv6"
21
22 DEPEND="doc? ( app-doc/halibut )"
23 RDEPEND="${DEPEND}"
24
25 src_prepare() {
26         epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
27         eautoreconf
28 }
29
30 src_configure() {
31         econf --enable-ipv4 \
32                 $(use_enable doc halibut) \
33                 $(use_enable ipv6)
34 }