net-libs/gnutls: libressl fix
[gentoo.git] / skel.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 # NOTE: The comments in this file are for instruction and documentation.
5 # They're not meant to appear with your final, production ebuild.  Please
6 # remember to remove them before submitting or committing your ebuild.  That
7 # doesn't mean you can't add your own comments though.
8
9 # The EAPI variable tells the ebuild format in use.
10 # It is suggested that you use the latest EAPI approved by the Council.
11 # The PMS contains specifications for all EAPIs. Eclasses will test for this
12 # variable if they need to use features that are not universal in all EAPIs.
13 EAPI=6
14
15 # inherit lists eclasses to inherit functions from. For example, an ebuild
16 # that needs the eautoreconf function from autotools.eclass won't work
17 # without the following line:
18 #inherit autotools
19 #
20 # eclasses tend to list descriptions of how to use their functions properly.
21 # take a look at /usr/portage/eclass/ for more examples.
22
23 # Short one-line description of this package.
24 DESCRIPTION="This is a sample skeleton ebuild file"
25
26 # Homepage, not used by Portage directly but handy for developer reference
27 HOMEPAGE="https://foo.example.org/"
28
29 # Point to any required sources; these will be automatically downloaded by
30 # Portage.
31 SRC_URI="ftp://foo.example.org/${P}.tar.gz"
32
33
34 # License of the package.  This must match the name of file(s) in
35 # /usr/portage/licenses/.  For complex license combination see the developer
36 # docs on gentoo.org for details.
37 LICENSE=""
38
39 # The SLOT variable is used to tell Portage if it's OK to keep multiple
40 # versions of the same package installed at the same time.  For example,
41 # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
42 # with 1.2.2), it would be optimal to instruct Portage to not remove
43 # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2.  To do this,
44 # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
45 # emerge clean understands SLOTs, and will keep the most recent version
46 # of each SLOT and remove everything else.
47 # Note that normal applications should use SLOT="0" if possible, since
48 # there should only be exactly one version installed at a time.
49 # Do not use SLOT="", because the SLOT variable must not be empty.
50 SLOT="0"
51
52 # Using KEYWORDS, we can record masking information *inside* an ebuild
53 # instead of relying on an external package.mask file.  Right now, you should
54 # set the KEYWORDS variable for every ebuild so that it contains the names of
55 # all the architectures with which the ebuild works.  All of the official
56 # architectures can be found in the arch.list file which is in
57 # /usr/portage/profiles/.  Usually you should just set this to "~amd64".
58 # The ~ in front of the architecture indicates that the package is new and
59 # should be considered unstable until testing proves its stability.  So, if
60 # you've confirmed that your ebuild works on amd64 and ppc, you'd specify:
61 # KEYWORDS="~amd64 ~ppc"
62 # Once packages go stable, the ~ prefix is removed.
63 # For binary packages, use -* and then list the archs the bin package
64 # exists for.  If the package was for an x86 binary package, then
65 # KEYWORDS would be set like this: KEYWORDS="-* x86"
66 # Do not use KEYWORDS="*"; this is not valid in an ebuild context.
67 KEYWORDS="~amd64"
68
69 # Comprehensive list of any and all USE flags leveraged in the ebuild,
70 # with some exceptions, e.g., ARCH specific flags like "amd64" or "ppc".
71 # Not needed if the ebuild doesn't use any USE flags.
72 IUSE="gnome X"
73
74 # A space delimited list of portage features to restrict. man 5 ebuild
75 # for details.  Usually not needed.
76 #RESTRICT="strip"
77
78
79 # Build-time dependencies, such as
80 #    ssl? ( >=dev-libs/openssl-0.9.6b )
81 #    >=dev-lang/perl-5.6.1-r1
82 # It is advisable to use the >= syntax show above, to reflect what you
83 # had installed on your system when you tested the package.  Then
84 # other users hopefully won't be caught without the right version of
85 # a dependency.
86 #DEPEND=""
87
88 # Run-time dependencies. Must be defined to whatever this depends on to run.
89 # The below is valid if the same run-time depends are required to compile.
90 RDEPEND="${DEPEND}"
91
92 # Source directory; the dir where the sources can be found (automatically
93 # unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
94 # If you don't need to change it, leave the S= line out of the ebuild
95 # to keep it tidy.
96 #S=${WORKDIR}/${P}
97
98
99 # The following src_configure function is implemented as default by portage, so
100 # you only need to call it if you need a different behaviour.
101 #src_configure() {
102         # Most open-source packages use GNU autoconf for configuration.
103         # The default, quickest (and preferred) way of running configure is:
104         #econf
105         #
106         # You could use something similar to the following lines to
107         # configure your package before compilation.  The "|| die" portion
108         # at the end will stop the build process if the command fails.
109         # You should use this at the end of critical commands in the build
110         # process.  (Hint: Most commands are critical, that is, the build
111         # process should abort if they aren't successful.)
112         #./configure \
113         #       --host=${CHOST} \
114         #       --prefix=/usr \
115         #       --infodir=/usr/share/info \
116         #       --mandir=/usr/share/man || die
117         # Note the use of --infodir and --mandir, above. This is to make
118         # this package FHS 2.2-compliant.  For more information, see
119         #   https://www.pathname.com/fhs/
120 #}
121
122 # The following src_compile function is implemented as default by portage, so
123 # you only need to call it, if you need different behaviour.
124 #src_compile() {
125         # emake is a script that calls the standard GNU make with parallel
126         # building options for speedier builds (especially on SMP systems).
127         # Try emake first.  It might not work for some packages, because
128         # some makefiles have bugs related to parallelism, in these cases,
129         # use emake -j1 to limit make to a single process.  The -j1 is a
130         # visual clue to others that the makefiles have bugs that have been
131         # worked around.
132
133         #emake
134 #}
135
136 # The following src_install function is implemented as default by portage, so
137 # you only need to call it, if you need different behaviour.
138 #src_install() {
139         # You must *personally verify* that this trick doesn't install
140         # anything outside of DESTDIR; do this by reading and
141         # understanding the install part of the Makefiles.
142         # This is the preferred way to install.
143         #emake DESTDIR="${D}" install
144
145         # When you hit a failure with emake, do not just use make. It is
146         # better to fix the Makefiles to allow proper parallelization.
147         # If you fail with that, use "emake -j1", it's still better than make.
148
149         # For Makefiles that don't make proper use of DESTDIR, setting
150         # prefix is often an alternative.  However if you do this, then
151         # you also need to specify mandir and infodir, since they were
152         # passed to ./configure as absolute paths (overriding the prefix
153         # setting).
154         #emake \
155         #       prefix="${D}"/usr \
156         #       mandir="${D}"/usr/share/man \
157         #       infodir="${D}"/usr/share/info \
158         #       libdir="${D}"/usr/$(get_libdir) \
159         #       install
160         # Again, verify the Makefiles!  We don't want anything falling
161         # outside of ${D}.
162 #}