app-misc/tmux: remove 2.5-r1 per shell-tools decision
[gentoo.git] / skel.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 # NOTE: The comments in this file are for instruction and documentation.
5 # They're not meant to appear with your final, production ebuild.  Please
6 # remember to remove them before submitting or committing your ebuild.  That
7 # doesn't mean you can't add your own comments though.
8
9 # The EAPI variable tells the ebuild format in use.
10 # It is suggested that you use the latest EAPI approved by the Council.
11 # The PMS contains specifications for all EAPIs. Eclasses will test for this
12 # variable if they need to use features that are not universal in all EAPIs.
13 EAPI=6
14
15 # inherit lists eclasses to inherit functions from. For example, an ebuild
16 # that needs the epatch function from eutils.eclass won't work without the
17 # following line:
18 inherit eutils
19 #
20 # eclasses tend to list descriptions of how to use their functions properly.
21 # take a look at /usr/portage/eclass/ for more examples.
22
23 # Short one-line description of this package.
24 DESCRIPTION="This is a sample skeleton ebuild file"
25
26 # Homepage, not used by Portage directly but handy for developer reference
27 HOMEPAGE="https://foo.example.org/"
28
29 # Point to any required sources; these will be automatically downloaded by
30 # Portage.
31 SRC_URI="ftp://foo.example.org/${P}.tar.gz"
32
33
34 # License of the package.  This must match the name of file(s) in
35 # /usr/portage/licenses/.  For complex license combination see the developer
36 # docs on gentoo.org for details.
37 LICENSE=""
38
39 # The SLOT variable is used to tell Portage if it's OK to keep multiple
40 # versions of the same package installed at the same time.  For example,
41 # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
42 # with 1.2.2), it would be optimal to instruct Portage to not remove
43 # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2.  To do this,
44 # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
45 # emerge clean understands SLOTs, and will keep the most recent version
46 # of each SLOT and remove everything else.
47 # Note that normal applications should use SLOT="0" if possible, since
48 # there should only be exactly one version installed at a time.
49 # DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
50 SLOT="0"
51
52 # Using KEYWORDS, we can record masking information *inside* an ebuild
53 # instead of relying on an external package.mask file.  Right now, you should
54 # set the KEYWORDS variable for every ebuild so that it contains the names of
55 # all the architectures with which the ebuild works.  All of the official
56 # architectures can be found in the arch.list file which is in
57 # /usr/portage/profiles/.  Usually you should just set this to "~x86".  The ~
58 # in front of the architecture indicates that the package is new and should be
59 # considered unstable until testing proves its stability.  So, if you've
60 # confirmed that your ebuild works on x86 and ppc, you'd specify:
61 # KEYWORDS="~x86 ~ppc"
62 # Once packages go stable, the ~ prefix is removed.
63 # For binary packages, use -* and then list the archs the bin package
64 # exists for.  If the package was for an x86 binary package, then
65 # KEYWORDS would be set like this: KEYWORDS="-* x86"
66 # DO NOT USE KEYWORDS="*".  This is deprecated and only for backward
67 # compatibility reasons.
68 KEYWORDS="~x86"
69
70 # Comprehensive list of any and all USE flags leveraged in the ebuild,
71 # with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
72 # "x86" and "alpha".  Not needed if the ebuild doesn't use any USE flags.
73 IUSE="gnome X"
74
75 # A space delimited list of portage features to restrict. man 5 ebuild
76 # for details.  Usually not needed.
77 #RESTRICT="strip"
78
79
80 # Build-time dependencies, such as
81 #    ssl? ( >=dev-libs/openssl-0.9.6b )
82 #    >=dev-lang/perl-5.6.1-r1
83 # It is advisable to use the >= syntax show above, to reflect what you
84 # had installed on your system when you tested the package.  Then
85 # other users hopefully won't be caught without the right version of
86 # a dependency.
87 #DEPEND=""
88
89 # Run-time dependencies. Must be defined to whatever this depends on to run.
90 # The below is valid if the same run-time depends are required to compile.
91 RDEPEND="${DEPEND}"
92
93 # Source directory; the dir where the sources can be found (automatically
94 # unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
95 # If you don't need to change it, leave the S= line out of the ebuild
96 # to keep it tidy.
97 #S=${WORKDIR}/${P}
98
99
100 # The following src_configure function is implemented as default by portage, so
101 # you only need to call it if you need a different behaviour.
102 #src_configure() {
103         # Most open-source packages use GNU autoconf for configuration.
104         # The default, quickest (and preferred) way of running configure is:
105         #econf
106         #
107         # You could use something similar to the following lines to
108         # configure your package before compilation.  The "|| die" portion
109         # at the end will stop the build process if the command fails.
110         # You should use this at the end of critical commands in the build
111         # process.  (Hint: Most commands are critical, that is, the build
112         # process should abort if they aren't successful.)
113         #./configure \
114         #       --host=${CHOST} \
115         #       --prefix=/usr \
116         #       --infodir=/usr/share/info \
117         #       --mandir=/usr/share/man || die
118         # Note the use of --infodir and --mandir, above. This is to make
119         # this package FHS 2.2-compliant.  For more information, see
120         #   https://www.pathname.com/fhs/
121 #}
122
123 # The following src_compile function is implemented as default by portage, so
124 # you only need to call it, if you need different behaviour.
125 #src_compile() {
126         # emake is a script that calls the standard GNU make with parallel
127         # building options for speedier builds (especially on SMP systems).
128         # Try emake first.  It might not work for some packages, because
129         # some makefiles have bugs related to parallelism, in these cases,
130         # use emake -j1 to limit make to a single process.  The -j1 is a
131         # visual clue to others that the makefiles have bugs that have been
132         # worked around.
133
134         #emake
135 #}
136
137 # The following src_install function is implemented as default by portage, so
138 # you only need to call it, if you need different behaviour.
139 #src_install() {
140         # You must *personally verify* that this trick doesn't install
141         # anything outside of DESTDIR; do this by reading and
142         # understanding the install part of the Makefiles.
143         # This is the preferred way to install.
144         #emake DESTDIR="${D}" install
145
146         # When you hit a failure with emake, do not just use make. It is
147         # better to fix the Makefiles to allow proper parallelization.
148         # If you fail with that, use "emake -j1", it's still better than make.
149
150         # For Makefiles that don't make proper use of DESTDIR, setting
151         # prefix is often an alternative.  However if you do this, then
152         # you also need to specify mandir and infodir, since they were
153         # passed to ./configure as absolute paths (overriding the prefix
154         # setting).
155         #emake \
156         #       prefix="${D}"/usr \
157         #       mandir="${D}"/usr/share/man \
158         #       infodir="${D}"/usr/share/info \
159         #       libdir="${D}"/usr/$(get_libdir) \
160         #       install
161         # Again, verify the Makefiles!  We don't want anything falling
162         # outside of ${D}.
163 #}