1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # NOTE: The comments in this file are for instruction and documentation.
5 # They're not meant to appear with your final, production ebuild. Please
6 # remember to remove them before submitting or committing your ebuild. That
7 # doesn't mean you can't add your own comments though.
9 # The EAPI variable tells the ebuild format in use.
10 # It is suggested that you use the latest EAPI approved by the Council.
11 # The PMS contains specifications for all EAPIs. Eclasses will test for this
12 # variable if they need to use features that are not universal in all EAPIs.
13 # If an eclass doesn't support latest EAPI, use the previous EAPI instead.
17 # inherit lists eclasses to inherit functions from. For example, an ebuild
18 # that needs the eautoreconf function from autotools.eclass won't work
19 # without the following line:
22 # Eclasses tend to list descriptions of how to use their functions properly.
23 # Take a look at the eclass/ directory for more examples.
25 # Short one-line description of this package.
26 DESCRIPTION="This is a sample skeleton ebuild file"
28 # Homepage, not used by Portage directly but handy for developer reference
29 HOMEPAGE="https://foo.example.org/"
31 # Point to any required sources; these will be automatically downloaded by
33 SRC_URI="ftp://foo.example.org/${P}.tar.gz"
35 # Source directory; the dir where the sources can be found (automatically
36 # unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
37 # If you don't need to change it, leave the S= line out of the ebuild
42 # License of the package. This must match the name of file(s) in the
43 # licenses/ directory. For complex license combination see the developer
44 # docs on gentoo.org for details.
47 # The SLOT variable is used to tell Portage if it's OK to keep multiple
48 # versions of the same package installed at the same time. For example,
49 # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
50 # with 1.2.2), it would be optimal to instruct Portage to not remove
51 # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
52 # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
53 # emerge clean understands SLOTs, and will keep the most recent version
54 # of each SLOT and remove everything else.
55 # Note that normal applications should use SLOT="0" if possible, since
56 # there should only be exactly one version installed at a time.
57 # Do not use SLOT="", because the SLOT variable must not be empty.
60 # Using KEYWORDS, we can record masking information *inside* an ebuild
61 # instead of relying on an external package.mask file. Right now, you
62 # should set the KEYWORDS variable for every ebuild so that it contains
63 # the names of all the architectures with which the ebuild works.
64 # All of the official architectures can be found in the arch.list file
65 # which is in the profiles/ directory. Usually you should just set this
66 # to "~amd64". The ~ in front of the architecture indicates that the
67 # package is new and should be considered unstable until testing proves
68 # its stability. So, if you've confirmed that your ebuild works on
69 # amd64 and ppc, you'd specify:
70 # KEYWORDS="~amd64 ~ppc"
71 # Once packages go stable, the ~ prefix is removed.
72 # For binary packages, use -* and then list the archs the bin package
73 # exists for. If the package was for an x86 binary package, then
74 # KEYWORDS would be set like this: KEYWORDS="-* x86"
75 # Do not use KEYWORDS="*"; this is not valid in an ebuild context.
78 # Comprehensive list of any and all USE flags leveraged in the ebuild,
79 # with some exceptions, e.g., ARCH specific flags like "amd64" or "ppc".
80 # Not needed if the ebuild doesn't use any USE flags.
83 # A space delimited list of portage features to restrict. man 5 ebuild
84 # for details. Usually not needed.
88 # Run-time dependencies. Must be defined to whatever this depends on to run.
90 # ssl? ( >=dev-libs/openssl-1.0.2q:0= )
91 # >=dev-lang/perl-5.24.3-r1
92 # It is advisable to use the >= syntax show above, to reflect what you
93 # had installed on your system when you tested the package. Then
94 # other users hopefully won't be caught without the right version of
98 # Build-time dependencies that need to be binary compatible with the system
99 # being built (CHOST). These include libraries that we link against.
100 # The below is valid if the same run-time depends are required to compile.
103 # Build-time dependencies that are executed during the emerge process, and
104 # only need to be present in the native build system (CBUILD). Example:
105 #BDEPEND="virtual/pkgconfig"
108 # The following src_configure function is implemented as default by portage, so
109 # you only need to call it if you need a different behaviour.
111 # Most open-source packages use GNU autoconf for configuration.
112 # The default, quickest (and preferred) way of running configure is:
115 # You could use something similar to the following lines to
116 # configure your package before compilation. The "|| die" portion
117 # at the end will stop the build process if the command fails.
118 # You should use this at the end of critical commands in the build
119 # process. (Hint: Most commands are critical, that is, the build
120 # process should abort if they aren't successful.)
124 # --infodir=/usr/share/info \
125 # --mandir=/usr/share/man || die
126 # Note the use of --infodir and --mandir, above. This is to make
127 # this package FHS 2.2-compliant. For more information, see
128 # https://wiki.linuxfoundation.org/lsb/fhs
131 # The following src_compile function is implemented as default by portage, so
132 # you only need to call it, if you need different behaviour.
134 # emake is a script that calls the standard GNU make with parallel
135 # building options for speedier builds (especially on SMP systems).
136 # Try emake first. It might not work for some packages, because
137 # some makefiles have bugs related to parallelism, in these cases,
138 # use emake -j1 to limit make to a single process. The -j1 is a
139 # visual clue to others that the makefiles have bugs that have been
145 # The following src_install function is implemented as default by portage, so
146 # you only need to call it, if you need different behaviour.
148 # You must *personally verify* that this trick doesn't install
149 # anything outside of DESTDIR; do this by reading and
150 # understanding the install part of the Makefiles.
151 # This is the preferred way to install.
152 #emake DESTDIR="${D}" install
154 # When you hit a failure with emake, do not just use make. It is
155 # better to fix the Makefiles to allow proper parallelization.
156 # If you fail with that, use "emake -j1", it's still better than make.
158 # For Makefiles that don't make proper use of DESTDIR, setting
159 # prefix is often an alternative. However if you do this, then
160 # you also need to specify mandir and infodir, since they were
161 # passed to ./configure as absolute paths (overriding the prefix
164 # prefix="${D}"/usr \
165 # mandir="${D}"/usr/share/man \
166 # infodir="${D}"/usr/share/info \
167 # libdir="${D}"/usr/$(get_libdir) \
169 # Again, verify the Makefiles! We don't want anything falling