dev-util/mdds: 1.1.0 version bump, bug 572616
[gentoo.git] / skel.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 # NOTE: The comments in this file are for instruction and documentation.
6 # They're not meant to appear with your final, production ebuild.  Please
7 # remember to remove them before submitting or committing your ebuild.  That
8 # doesn't mean you can't add your own comments though.
9
10 # The 'Id' on the third line should just be left alone.  When your ebuild
11 # will be committed to git, the details on that line will be automatically
12 # generated to contain the correct data.
13
14 # The EAPI variable tells the ebuild format in use.
15 # It is suggested that you use the latest EAPI approved by the Council.
16 # The PMS contains specifications for all EAPIs. Eclasses will test for this
17 # variable if they need to use features that are not universal in all EAPIs.
18 EAPI=6
19
20 # inherit lists eclasses to inherit functions from. For example, an ebuild
21 # that needs the epatch function from eutils.eclass won't work without the
22 # following line:
23 inherit eutils
24 #
25 # eclasses tend to list descriptions of how to use their functions properly.
26 # take a look at /usr/portage/eclass/ for more examples.
27
28 # Short one-line description of this package.
29 DESCRIPTION="This is a sample skeleton ebuild file"
30
31 # Homepage, not used by Portage directly but handy for developer reference
32 HOMEPAGE="https://foo.example.org/"
33
34 # Point to any required sources; these will be automatically downloaded by
35 # Portage.
36 SRC_URI="ftp://foo.example.org/${P}.tar.gz"
37
38
39 # License of the package.  This must match the name of file(s) in
40 # /usr/portage/licenses/.  For complex license combination see the developer
41 # docs on gentoo.org for details.
42 LICENSE=""
43
44 # The SLOT variable is used to tell Portage if it's OK to keep multiple
45 # versions of the same package installed at the same time.  For example,
46 # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
47 # with 1.2.2), it would be optimal to instruct Portage to not remove
48 # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2.  To do this,
49 # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
50 # emerge clean understands SLOTs, and will keep the most recent version
51 # of each SLOT and remove everything else.
52 # Note that normal applications should use SLOT="0" if possible, since
53 # there should only be exactly one version installed at a time.
54 # DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
55 SLOT="0"
56
57 # Using KEYWORDS, we can record masking information *inside* an ebuild
58 # instead of relying on an external package.mask file.  Right now, you should
59 # set the KEYWORDS variable for every ebuild so that it contains the names of
60 # all the architectures with which the ebuild works.  All of the official
61 # architectures can be found in the arch.list file which is in
62 # /usr/portage/profiles/.  Usually you should just set this to "~x86".  The ~
63 # in front of the architecture indicates that the package is new and should be
64 # considered unstable until testing proves its stability.  So, if you've
65 # confirmed that your ebuild works on x86 and ppc, you'd specify:
66 # KEYWORDS="~x86 ~ppc"
67 # Once packages go stable, the ~ prefix is removed.
68 # For binary packages, use -* and then list the archs the bin package
69 # exists for.  If the package was for an x86 binary package, then
70 # KEYWORDS would be set like this: KEYWORDS="-* x86"
71 # DO NOT USE KEYWORDS="*".  This is deprecated and only for backward
72 # compatibility reasons.
73 KEYWORDS="~x86"
74
75 # Comprehensive list of any and all USE flags leveraged in the ebuild,
76 # with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
77 # "x86" and "alpha".  Not needed if the ebuild doesn't use any USE flags.
78 IUSE="gnome X"
79
80 # A space delimited list of portage features to restrict. man 5 ebuild
81 # for details.  Usually not needed.
82 #RESTRICT="strip"
83
84
85 # Build-time dependencies, such as
86 #    ssl? ( >=dev-libs/openssl-0.9.6b )
87 #    >=dev-lang/perl-5.6.1-r1
88 # It is advisable to use the >= syntax show above, to reflect what you
89 # had installed on your system when you tested the package.  Then
90 # other users hopefully won't be caught without the right version of
91 # a dependency.
92 #DEPEND=""
93
94 # Run-time dependencies. Must be defined to whatever this depends on to run.
95 # The below is valid if the same run-time depends are required to compile.
96 RDEPEND="${DEPEND}"
97
98 # Source directory; the dir where the sources can be found (automatically
99 # unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
100 # If you don't need to change it, leave the S= line out of the ebuild
101 # to keep it tidy.
102 #S=${WORKDIR}/${P}
103
104
105 # The following src_configure function is implemented as default by portage, so
106 # you only need to call it if you need a different behaviour.
107 #src_configure() {
108         # Most open-source packages use GNU autoconf for configuration.
109         # The default, quickest (and preferred) way of running configure is:
110         #econf
111         #
112         # You could use something similar to the following lines to
113         # configure your package before compilation.  The "|| die" portion
114         # at the end will stop the build process if the command fails.
115         # You should use this at the end of critical commands in the build
116         # process.  (Hint: Most commands are critical, that is, the build
117         # process should abort if they aren't successful.)
118         #./configure \
119         #       --host=${CHOST} \
120         #       --prefix=/usr \
121         #       --infodir=/usr/share/info \
122         #       --mandir=/usr/share/man || die
123         # Note the use of --infodir and --mandir, above. This is to make
124         # this package FHS 2.2-compliant.  For more information, see
125         #   https://www.pathname.com/fhs/
126 #}
127
128 # The following src_compile function is implemented as default by portage, so
129 # you only need to call it, if you need different behaviour.
130 #src_compile() {
131         # emake is a script that calls the standard GNU make with parallel
132         # building options for speedier builds (especially on SMP systems).
133         # Try emake first.  It might not work for some packages, because
134         # some makefiles have bugs related to parallelism, in these cases,
135         # use emake -j1 to limit make to a single process.  The -j1 is a
136         # visual clue to others that the makefiles have bugs that have been
137         # worked around.
138
139         #emake
140 #}
141
142 # The following src_install function is implemented as default by portage, so
143 # you only need to call it, if you need different behaviour.
144 #src_install() {
145         # You must *personally verify* that this trick doesn't install
146         # anything outside of DESTDIR; do this by reading and
147         # understanding the install part of the Makefiles.
148         # This is the preferred way to install.
149         #emake DESTDIR="${D}" install
150
151         # When you hit a failure with emake, do not just use make. It is
152         # better to fix the Makefiles to allow proper parallelization.
153         # If you fail with that, use "emake -j1", it's still better than make.
154
155         # For Makefiles that don't make proper use of DESTDIR, setting
156         # prefix is often an alternative.  However if you do this, then
157         # you also need to specify mandir and infodir, since they were
158         # passed to ./configure as absolute paths (overriding the prefix
159         # setting).
160         #emake \
161         #       prefix="${D}"/usr \
162         #       mandir="${D}"/usr/share/man \
163         #       infodir="${D}"/usr/share/info \
164         #       libdir="${D}"/usr/$(get_libdir) \
165         #       install
166         # Again, verify the Makefiles!  We don't want anything falling
167         # outside of ${D}.
168 #}