Drop $Id$ per council decision in bug #611234.
[gentoo.git] / sci-visualization / veusz / veusz-1.11.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="3"
5 PYTHON_DEPEND="2"
6 SUPPORT_PYTHON_ABIS="1"
7 RESTRICT_PYTHON_ABIS="3.* *-jython"
8
9 inherit distutils eutils fdo-mime
10
11 DESCRIPTION="Qt based scientific plotting package with good Postscript output"
12 HOMEPAGE="http://home.gna.org/veusz/ https://pypi.python.org/pypi/veusz"
13 SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
14
15 IUSE="doc examples fits"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 LICENSE="GPL-2"
19
20 DEPEND="dev-python/numpy"
21 RDEPEND="${DEPEND}
22         dev-python/PyQt4[X,svg]
23         fits? ( dev-python/pyfits )"
24
25 PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
26
27 src_install() {
28         distutils_src_install
29         insinto /usr/share/doc/${PF}
30         if use examples; then
31                 doins -r examples || die "examples install failed"
32         fi
33         if use doc; then
34                 cd Documents
35                 insinto /usr/share/doc/${PF}
36                 doins manual.pdf || die "doins failed"
37                 insinto /usr/share/doc/${PF}/html
38                 doins -r manual.html manimages \
39                         || die "doc install failed"
40         fi
41         newicon "${S}"/windows/icons/veusz_48.png veusz.png
42         domenu "${FILESDIR}"/veusz.desktop || die "domenu failed"
43         insinto /usr/share/mime/packages
44         doins "${FILESDIR}"/veusz.xml || die "doins failed"
45 }
46
47 pkg_postinst() {
48         distutils_pkg_postinst
49         fdo-mime_desktop_database_update
50 }
51
52 pkg_postrm() {
53         distutils_pkg_postrm
54         fdo-mime_desktop_database_update
55 }