www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / sci-visualization / quickplot / quickplot-1.0.1_rc.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils
7
8 MY_P=${P/_rc/rc}
9
10 DESCRIPTION="A fast interactive 2D plotter"
11 HOMEPAGE="http://quickplot.sourceforge.net/ https://github.com/lanceman2/quickplot"
12 SRC_URI="https://github.com/lanceman2/${PN}/archive/${MY_P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-3"
16 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
17 IUSE="static-libs"
18
19 RDEPEND="
20         media-libs/libsndfile
21         >=sys-libs/readline-0.6.2:0=
22         x11-libs/gtk+:3"
23 DEPEND="${RDEPEND}
24         media-gfx/imagemagick
25         virtual/pkgconfig
26         www-client/lynx"
27
28 S="${WORKDIR}/${PN}-${MY_P}"
29
30 src_prepare() {
31         sed -i \
32                 -e '/libquickplot_la_LIBADD/s:$: -lm:g' \
33                 -e 's/ $(htmldir)/ $(DESTDIR)$(htmldir)/g' \
34                 Makefile.am || die
35         default
36         eautoreconf
37 }
38
39 src_configure() {
40         econf \
41                 --enable-developer \
42                 $(use_enable static-libs static)
43 }
44
45 src_install() {
46         default
47         make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
48         mv "${ED%/}"/usr/share/applications/quickplot{*,}.desktop || die
49 }