dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / sci-physics / looptools / looptools-2.8.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils fortran-2 multilib
7
8 MYP=LoopTools-${PV}
9
10 DESCRIPTION="Tools for evaluation of scalar and tensor one-loop integrals"
11 HOMEPAGE="http://www.feynarts.de/looptools"
12 SRC_URI="http://www.feynarts.de/looptools/${MYP}.tar.gz"
13
14 LICENSE="LGPL-3"
15
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="doc static-libs"
19
20 S="${WORKDIR}/${MYP}"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${P}-makefile.patch
24         export VER="${PV}"
25         # necessary fix for prefix
26         sed -i "s/lib\$(LIBDIRSUFFIX)/$(get_libdir)/" makefile.in || die
27 }
28
29 src_install() {
30         default
31         # another one of these package building archive with pic
32         # no: ooptools is not a typo
33         if use static-libs; then
34                 rm "${ED}"/usr/$(get_libdir)/libooptools.a || die
35         fi
36         use doc && dodoc manual/*.pdf
37 }