sci-electronics/gresistor: Switch to PYTHON_MULTI_USEDEP API
[gentoo.git] / sci-misc / vitables / vitables-3.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DISTUTILS_SINGLE_IMPL=1
7 PYTHON_COMPAT=( python3_6 )
8
9 inherit distutils-r1
10
11 MY_P=ViTables-${PV}
12
13 DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
14 HOMEPAGE="http://vitables.org/"
15 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
20
21 RDEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         dev-python/pytables[${PYTHON_USEDEP}]
24         dev-python/QtPy[gui,${PYTHON_USEDEP}]"
25 DEPEND="${RDEPEND}"
26
27 S=${WORKDIR}/${MY_P}
28
29 python_prepare_all() {
30         # remove the PyQt5 dependency
31         # because PyQt5 in Gentoo does not provide egg-info
32         # see also: https://github.com/pyqt/python-qt5/issues/18
33         sed "s:'PyQt5 [^ ]*::" -i setup.py || die
34
35         distutils-r1_python_prepare_all
36 }