dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-misc / flashdot / flashdot-1.1.4-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Generator for psychophysical experiments"
7 HOMEPAGE="http://www.flashdot.info/"
8 SRC_URI="mirror://gentoo/${P}.tar.bz2
9         https://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
10
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="+ocamlopt"
15
16 DEPEND="
17         >=dev-lang/ocaml-3.10[ocamlopt?]
18         dev-ml/gsl-ocaml
19         dev-ml/lablgl[glut]
20         dev-ml/ocamlsdl
21         x11-apps/xdpyinfo"
22 RDEPEND="${DEPEND}"
23 PATCHES=(
24         "${FILESDIR}/${P}-gsl-ocaml.patch"
25 )
26
27 src_prepare() {
28         default
29         MAKEOPTS+=" -j1 VERSION=${PV}"
30         use ocamlopt || MAKEOPTS+=" TARGETS=flashdot_bytecode BYTECODENAME=flashdot"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" CALLMODE=script install
35 }