sci-mathematics/fricas: bump to 1.3.6
[gentoo.git] / sci-mathematics / wxmaxima / wxmaxima-20.01.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 WX_GTK_VER="3.0"
6 PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
7 inherit cmake-utils wxwidgets l10n xdg
8
9 DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
10 HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
11 SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17 S="${WORKDIR}"/${PN}-Version-${PV}
18
19 DEPEND="
20         dev-libs/libxml2:2
21         x11-libs/wxGTK:${WX_GTK_VER}"
22 RDEPEND="${DEPEND}
23         media-fonts/jsmath
24         sci-visualization/gnuplot[wxwidgets]
25         sci-mathematics/maxima"
26
27 src_prepare() {
28         setup-wxwidgets
29         cmake-utils_src_prepare
30
31         sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
32                 || die "sed info/CMakeLists.txt failed"
33
34         # locales
35         rm_po() {
36                 rm "${S}"/locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
37                 rm -f "${S}"/locales/manual/${1}.po
38                 rm -f "${S}"/locales/wxwin/${1}.po
39                 rm -f "${S}"/info/${PN}.${1}.md
40                 rm -f "${S}"/info/${PN}.${1}.html
41         }
42         l10n_find_plocales_changes "${S}"/locales/wxMaxima '' '.po'
43         l10n_for_each_disabled_locale_do rm_po
44 }
45
46 src_install() {
47         docompress -x /usr/share/doc/${PF}
48         cmake-utils_src_install
49 }