sci-mathematics/alt-ergo: fix dependency
[gentoo.git] / sci-mathematics / planarity / planarity-3.0.0.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_PN="edge-addition-planarity-suite-Version"
7 DESCRIPTION="The edge addition planarity suite of graph algorithms"
8 HOMEPAGE="https://github.com/graph-algorithms/edge-addition-planarity-suite/"
9
10 # Use the tarball from sage because the github release doesn't
11 # contain the generated autotools files (like ./configure).
12 SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
13 IUSE="examples static-libs"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18
19 # https://github.com/graph-algorithms/edge-addition-planarity-suite/issues/4
20 # https://github.com/graph-algorithms/edge-addition-planarity-suite/pull/3
21 PATCHES=( "${FILESDIR}/${P}-extern.patch" )
22
23 S="${WORKDIR}/${MY_PN}_${PV}"
24
25 src_configure() {
26         econf $(use_enable static-libs static)
27 }
28
29 src_install() {
30         default
31         find "${ED}" -name '*.la' -delete || die
32         use examples && dodoc -r c/samples
33 }