sci-mathematics/rstudio: Patch 1.2.5033 for boost 1.73.0
[gentoo.git] / sci-mathematics / mathomatic / mathomatic-15.8.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit toolchain-funcs flag-o-matic
6
7 DESCRIPTION="Automatic algebraic manipulator"
8 HOMEPAGE="http://www.mathomatic.org/"
9 SRC_URI="http://www.mathomatic.org/archive/${P}.tar.bz2"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="amd64 ppc x86"
14 IUSE="doc gnuplot"
15
16 DEPEND="sys-libs/readline
17         sys-libs/ncurses"
18 RDEPEND="${DEPEND}
19         gnuplot? ( sci-visualization/gnuplot )"
20
21 src_compile() {
22         append-cflags -DBOLD_COLOR=1
23         emake READLINE=1 CC=$(tc-getCC)
24         emake CC=$(tc-getCC) -C primes
25 }
26
27 src_test() {
28         default
29         emake -C primes check
30 }
31
32 src_install() {
33         emake prefix="${EPREFIX}usr" DESTDIR="${D}" bininstall
34         emake prefix="${EPREFIX}usr" DESTDIR="${D}" -C primes install
35         dodoc changes.txt README.txt AUTHORS
36         newdoc primes/README.txt README-primes.txt
37         use doc && emake \
38                 prefix="${EPREFIX}usr" \
39                 mathdocdir="${EPREFIX}usr/share/doc/${PF}" \
40                 DESTDIR="${D}" docinstall
41 }