sci-mathematics/glpk: amd64 stable wrt bug #717072
[gentoo.git] / sci-mathematics / mathmod / mathmod-4.1-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils gnome2-utils qmake-utils fdo-mime
6
7 DESCRIPTION="Plot parametric and implicit surfaces"
8 HOMEPAGE="https://www.facebook.com/pages/MathMod/529510253833102"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.src.zip"
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 RDEPEND="dev-qt/qtwidgets:5 dev-qt/qtopengl:5"
16 DEPEND="${RDEPEND}"
17
18 S="${WORKDIR}"/${PN}-branches-274-trunk
19
20 src_configure() {
21         eqmake5 MathMod.pro
22 }
23
24 src_install() {
25         exeinto /usr/bin
26         doexe MathMod
27         insinto /usr/share/${P}
28         doins mathmodconfig.js mathmodcollection.js advancedmodels.js
29         newicon -s 16 icon/catenoid_mini_16x16.png catenoid.png
30         newicon -s 32 icon/catenoid_mini_32x32.png catenoid.png
31         newicon -s 64 icon/catenoid_mini_64x64.png catenoid.png
32         make_desktop_entry MathMod MathMod catenoid
33 }
34
35 pkg_postinst() {
36         gnome2_icon_cache_update
37         fdo-mime_desktop_database_update
38 }
39
40 pkg_postrm() {
41         gnome2_icon_cache_update
42         fdo-mime_desktop_database_update
43 }