dev-texlive/texlive-formatsextra: x86 stable wrt bug #723404
[gentoo.git] / sci-mathematics / lpsolve / lpsolve-5.5.2.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Mixed Integer Linear Programming (MILP) solver"
7 HOMEPAGE="https://sourceforge.net/projects/lpsolve/"
8 SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
13 IUSE="static-libs"
14
15 DEPEND="sci-libs/colamd"
16 RDEPEND="${DEPEND}"
17
18 src_configure() {
19         econf \
20                 $(use_enable static-libs static)
21 }
22
23 src_install() {
24         default
25
26         # required because it does not provide .pc file
27         if ! use static-libs; then
28                 find "${D}" -name '*.la' -delete || die
29         fi
30 }