sci-mathematics/agda-lib-ffi: update homepage
[gentoo.git] / sci-mathematics / fann / fann-2.2.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_P=FANN-${PV}-Source
7 inherit cmake-multilib
8
9 DESCRIPTION="Fast Artificial Neural Network Library"
10 HOMEPAGE="http://leenissen.dk/fann/"
11 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE="examples"
17
18 RDEPEND=""
19 DEPEND="app-arch/unzip"
20
21 S="${WORKDIR}/${MY_P}"
22
23 PATCHES=( "${FILESDIR}/${P}-examples.patch" )
24
25 src_test() {
26         cd examples || die
27         emake CFLAGS="${CFLAGS} -I../src/include -L${BUILD_DIR}/src"
28         LD_LIBRARY_PATH="${BUILD_DIR}/src" emake runtest
29         emake clean
30 }
31
32 src_install() {
33         cmake-multilib_src_install
34         if use examples; then
35                 insinto /usr/share/doc/${PF}
36                 doins -r examples
37         fi
38 }